Latest Neocron News and Information

Weird Sound Bug in Neocron (Classic)

For all discussion about the Neocron 2 world.

Moderator: Tech Haven Network - Moderator team

Weird Sound Bug in Neocron (Classic)

Postby Bapho » Mon Jan 28, 2019 12:53 pm

Hey guys!

If the topic is a bit out of place here, please forgive. I'm on the verge of despair .
Basically, me and a buddy of mine both having the same problem in Neocron Classic. We're both on Win 10 64bit.
Unfortunately, specific forums are all closed and I was not able to find anything on the net after 2 days of searching. That's why I turn to this one..

The problem:
Not all sounds are played, certain sound effects such as fired shots of the opponents, melee noises, etc. are just not played.

Since this can be quite annoying (you die a lot when acoustic damage indicators are completely gone..) and I have already done a great deal and tried to master the problem, but could not solve it so far.
I wanted to make a video of it to better represent the error but here it comes:
In the video, the sounds that are not played in the game are recorded !! : Blink:

This is certainly the weirdest bug I've ever encountered.
I've recorded it with the Windows on board recording tool. (Win key + G)
Perhaps any of you guys knows this error?

What I have tried so far:
- Compatibility modes in all conceivable variants that make sense. I've tried every option until Win XP SP 3. Run as admin, ofc.
- Updated audio driver
- Audio Hardware acceleration disabled (via registry, because Win 10 does not allow it any other way ...)
- of course played around with the ingame sound settings, the controls are now all on the attack.

Haven't built in any sound card, just on board sound.
Wanted to upload DxDiag file - forum rules won't allow (tried *.txt and *.pdf..).

Thanks and Greetings,
THN nib
Posts: 2
Joined: Mon Jan 28, 2019 12:39 pm
Faction: Crahn

Re: Weird Sound Bug in Neocron (Classic)

Postby Bapho » Sat Feb 02, 2019 10:20 am

Solved it. Despite my system stated that my drivers were up to date, they weren't. For those who have the same issue: I've installed the latest Realtek driver from this site: ... 97342.html and it works like a charm now on WIn 10, 64bit. I thought I'd let you know.
THN nib
Posts: 2
Joined: Mon Jan 28, 2019 12:39 pm
Faction: Crahn

Re: Weird Sound Bug in Neocron (Classic)

Postby RaymondB » Mon Apr 01, 2019 11:33 am

I take it that site is reputable? Is it the official site for the Realtek drivers?
THN nib
Posts: 1
Joined: Sat Mar 30, 2019 9:52 am

Return to Tech Haven Sector 2

Who is online

Users browsing this forum: No registered users and 2 guests